www.3112.net > 系统uBuntu,服务器ApAChE,想把php5.5降级到5.2

系统uBuntu,服务器ApAChE,想把php5.5降级到5.2

直接卸载php5.5,重装php5.2

1)如果Ubuntu软件源里有php5.3,那就容易了。 具体的话,用 Synaptic(没有就装一个) 搜 php 2)没有的话,就要自己编译php5.3。 编译的话如下命令仅供参考 ./configure --prefix=/usr/local/php --with-mysql=你的MySQL程序路径 --enable-mbs...

完全可以,都是免费的,$sudo apt-get install apache2 $sudo apt-get install php5 等命令即可

重新下载php5.3的源码,然后编译时的prefix指向另一个目录,编译完后再更改下服务器的配置文件 ,把原来的关于php路径的配置更注释掉,然后将新的配置写进去,重启下服务器就可以了,后面还可以通过注释的方式在版本之间进行切换

Ubuntu建立(apache+php+mysql)+phpmyadmin Ubuntu建立apache+php+mysql 基本的支持环境。暂时还不应用zend优化,因此这里就不涉及到zend optimizer的安装了。其实在ubuntu系统中中安装远比在windows系统中设置更为容易,而且在终端下设置更省事...

不管什么系统都需要安装web服务器,appache活着nginx, web服务器安装路径下面会有一个网页根目录,www 或着wwwroot, 把php文件放到这个目录里面

版本的单词version,简写v。 apache root@ubuntu:~# apachectl -vServer version: Apache/2.4.7 (Ubuntu)Server built: Jul 15 2016 15:34:04nginx root@ubuntu:~# nginx -vnginx version: nginx/1.4.6 (Ubuntu)php root@ubuntu:~# php -vPHP 5....

你代码打错了吧,第一行的?应该在

这说明你这个 php 不是通过 apt 安装的。 使用 locate php 或 find . -iname php / 看看你的php安装到哪里了

我的Ubuntu下如下配置就可以了: sudo vi /etc/apache2/envvars 将下面2行改成普通能够登陆系统的账户就可以了,比如 export APACHE_RUN_USER=qunero #设置用户为qunero export APACHE_RUN_GROUP=www-data #设置组为 www-data 重启服务:sudo se...

网站地图

All rights reserved Powered by www.3112.net

copyright ©right 2010-2021。
www.3112.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com