www.3112.net > linux下安装rpm遇到的包依赖问题

linux下安装rpm遇到的包依赖问题

1.加上 --nodeps,意思不考虑依赖 2.更狠的--force,强制安装 你可以在这两个之前试试--aid自己解决依赖

1.加上 --nodeps,意思不考虑依赖2.更狠的--force,强制安装你可以在这两个之前试试--aid自己解决依赖

表示nsmbd这个包要依靠或调用libc.so.6,libpam.so.0等等这些的函数库或其他类似数据。所以要解决就必须安装这4个东西。 如果你是RH的,就#YUM INSTALL GLIBC—2。4。。。括号里面的那个名称 依次装完就可以装nsmbd。 如果ubuntu或dbian 就#apt-...

warning: epel-release-6-5.noarch.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 0608b895 key部队,要导入当前版本的keyrpm --import /etc/pki/rpm-gpg/RPM* error: Failed dependencies: rpmlib(FileDigests)

你的命令没有问题。 rpm-5.1.6.tar.gz不是rpm包,是一个gz的压缩包,用tar -xzvf rpm-5.1.6.tar.gz是可以解压成功的。 如果你要装rpm包,应该是 rpm -ivh 包名,或者你那个rpm-5.1.6.tar.gz原本是rpm包,后来被重命名了,你用rpm -ivh rpm-5.1.6....

你把类似这个的rpm包安装一下 perl-5.10.1-136.el6.x86_64 我是redhat6.5的,你找下你centos7的perl的对应版本

cd到你存放rpm文件包的目录 rpm -ivh linuxqq-v1.0.2-beta1.i386.rpm 安装时可能会遇到缺少包的错误。 rpm -ivh --replacepkgs webmin-1.290-1.noarch.rpm 软件包重复安装将会失败,若仍需要安装必须加--replacepkgs rpm -ivh --replacefiles we...

yum list |grep 软件名称 看下有没有想要的低版本,有的话yum安装跟上版本号,如果没有那么就需要搜索下源码下载编译安装; 安装devel版本需要安装非devel yum install pcre pcre-devel

你这几个不是针对你当前系统的包吧? 这几个依赖都算是是基本库,应该你的系统自带了。你这可能是版本不对应导致 so 后面的那个接口版本号不一致。 rpm -q 只是搜索他自己的数据库,这个数据库只有已经安装的软件书记。找不到的依赖,你再怎么用...

原因:fpc-src-2.4.2-0.i686.rpm所依赖的包没有安装上。 最简单的办法: 安装yum 然后用yum install -y fpc-src //yum 安装可以解决rpm包依赖. 比较笨的方法: 如果你有你安装的linux系统的ISO或安装盘解压后从server(red hat 和centos两个系统...

网站地图

All rights reserved Powered by www.3112.net

copyright ©right 2010-2021。
www.3112.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com