www.3112.net > tomCAt8支持jDk1.7吗

tomCAt8支持jDk1.7吗

jdk版本的设计是向后兼容的,即高版本支持低版本,所以tomcat6支持jdk1.8的.

tomcat8支持jdk1.7

你说反了,而应该问jdk1.8支持tomcat7吗?tomcat底层运行的就是java的Socket,也就是说tomcat是在jdk环境下运行的.而且这也不是问题,tomcat本来就是用java语言写的,java版本高1.8肯定支持tomcat7了,好像tomcat7在某个版本(7.0.72,具体记不清楚了)之前还是用jdk1.6写的,7.0.72之后是jdk1.7写的.那么jdk1.8肯定是支持tomcat7的

不是必须的,但是要注意:java是向下兼容的JDK,eclipse,tomcat的位数与系统位数最好一致Eclipse 是一个开放源代码的、基于Java的可扩展开发平台.就其本身而言,它只是一个框架和一组服务,用于通过插件组件构建开发环境.幸运的是,Eclipse 附带了一个标准的插件集,包括Java开发工具(Java Development Kit,JDK).

不兼容,建议都换成7/或者8

你装的是tomcat几的版本,是tomcat 5还是6.0还是7.0的,tomcat6.0版本之前的比如tomcat5和tomcat4就有common文件夹,tomcat6.0和tomcat7.0就是没有这个文件夹的

比如tomcat7,对应的jdk就是1.7.tomcat8,对应的就是jdk1.8 依次类推支持的

下面这段信息是我配置tomcat 8.5的时候报错的!只支持到1.7Tomcat version 8.5 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5, 6, and 7 Web modules

tomcat7.x支持jdk1.8jdk是 Java 语言的软件开发工具包,主要用于移动设备、嵌入式设备上的java应用程序.

可以的,高版本兼容低版本的,但是最好还是用对应的版本,下载也很简单的

网站地图

All rights reserved Powered by www.3112.net

copyright ©right 2010-2021。
www.3112.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com